Back to overview
Resolved
Hourly data update failed.
May 23, 2026 at 8:45pm UTC
Affected services
Data Updates
Resolved
May 23, 2026 at 9:14pm UTC
The issue was resolved and all data fixed.
Affected services
Updated
May 23, 2026 at 8:57pm UTC
We have identified the issue and are working on a fix.
Affected services
Created
May 23, 2026 at 8:45pm UTC
We are seeing problems with the hourly update.
Affected services